Joe's Blog

line

A blog by Joe Billman about programming, and other stuff

line

Archive for July, 2012

Flash Builder 4.6 Won’t Start

Posted on: July 14th, 2012 by Joe

line 9 Comments

I recently updated to CS6 and everything was working great until one day I tried to open Flash Builder and it wouldn’t open. It would pull up the Splash screen for a few seconds and then silently die. I’ve had something similar to this happen in the past and it was usually due to a file in the workspace getting corrupted and was an easy fix. You simply renamed or moved the workspace folder, launched Flash Builder so that it created a new workspace folder and then replaced the files in the new folder with the old one. This time however that didn’t work. So after a couple of hours of trying everything I could think of from uninstalling and re-installing to attempting to pull out all of the hair that I wish I had, I finally came across the answer. I read online that people were having problems getting Acrobat X to open. So I tried to open it on my machine and sure enough it wouldn’t open. After reading further online I discovered that other people had fixed this problem by opening Photoshop, deactivating, then re-opening Photoshop and activating again. So I did that and both Acrobat X and Flash Builder 4.6 launched like normal. With Adobe CS6 they have gone to a new activation model that requires you to put in the license key along with your Adobe ID. My guess is that there is an issue where after the trial period has ended (even though you activated it) it deactivates. Not sure but deactivating and re-activating solved it for me. So if Flash Builder or Acrobat won’t open, give this solution a try.

PS
I am using a PC with Windows 7 and am not sure if this problem exists on Mac.


Warning: Use of undefined constant Y - assumed 'Y' (this will throw an Error in a future version of PHP) in /homepages/16/d145171736/htdocs/php/footer.php on line 1